Home > J2ME, programming > J2MEPolish 2.0 and NetBeans 6.9…

J2MEPolish 2.0 and NetBeans 6.9…


Yeah, it is kind a hard to get them together…

Even after successful installation of J2MEPolish with its NetBeans integration module you have absolutely no idea what to do next…
Starting new project as J2MEPolish Project in NetBeans’ wizard is somewhat crappy, it leads to empty project with some java exceptions in IDE’s log.
One another problem – NetBeans doesn’t allow configurations to have names like “Nokia/E50”, because slash is not allowed in correct java identifier… so it is not so-straighforward to define device identifier for J2MEPolish.

Copying sample project from J2MEPolish/sample directory won’t lead you to working framework, too.

It would be the best, when I share a simple framework with you, because I could not reproduce the way I’ve got through 🙂

http://rapidshare.com/files/405096758/J2ME-Polish-Project.zip.html

It is compiling, building and running on my machine with J2ME SDK 3.0 platform and Nokia S40 SDKs.

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: